当前位置:首页 > 问答

选股公式通达

我来帮TA回答

请问怎样把下面的指标公式改成选股公式(通达软件)

VAR14:=ZIG(3,13);
XG:REF(VAR14,2)>REF(VAR14,1) AND VAR14>REF(VAR14,1);
(友情提示:有未来函数。慎用)

高分求高手给做个通达顺的选股公式

过程描述有些模糊,比如 "很多天" "附近" 这些词不够精确,
如果愿意,可以Q我说得更清楚些

通达信自编的选股公式如何使用

要改成选股公式,只能一条输出,其他都要加上等号.
公式一是可以的.
公式二要改一下.
--------------------
SHORT:=12;
LONG:=26;
MID:=9;
DIF:=EMA(CLOSE,SHORT)-EMA(CLOSE,LONG);
DEA:=EMA(DIF,MID);
MACD:=(DIF-DEA)*2;
选股:DIF<0 AND DEA<0 AND CROSS(DIF,DEA);{低位金叉选股}
----------------------------
选股公式编到条件选股---其他类型;

求通达信选股公式,形态选股

第一个

T1:=COUNT(MA(C,5)>MA(C,10) AND MA(C,10)>MA(C,20),5)=5;

T2:=REF(O,3)>=REF(MAX(C,O),4) AND REF(C,3)>REF(O,3) AND REF(C,3)>REF(HHV(MAX(C,O),20),4)

AND REF(H,3)>REF(HHV(H,20),4) AND REF(V,3)>REF(V,4)

AND (REF(V,2)<REF(V,3) OR REF(V,1)<REF(V,3))

AND REF(C,2)<REF(C,3) AND REF(C,1)<REF(C,3)

AND REF(L,2)>REF(L,3)-0.05 AND REF(L,1)>REF(L,3)-0.05

AND V>REF(HHV(V,2),1) AND C>O AND  H>REF(HHV(H,20),1) AND C>REF(C,4);

XG:T1=1 AND COUNT(T2=1,2)>0;

第二个

T1:=COUNT(MA(C,5)>MA(C,10) AND MA(C,10)>MA(C,20),5)=5;

T2:=REF(C,3)>REF(O,3) AND REF(C,3)>REF(HHV(MAX(C,O),20),4)

AND REF(H,3)>REF(HHV(H,20),4) AND REF(V,3)>REF(V,4)

AND (REF(V,2)<REF(V,3) OR REF(V,1)<REF(V,3))

AND REF(C,2)<REF(C,3) AND REF(C,1)<REF(C,3)

AND REF(L,2)>REF(L,3)-0.05 AND REF(L,1)>REF(L,3)-0.05

AND V>REF(HHV(V,2),1) AND C>O AND  H>REF(HHV(H,20),1) AND C>REF(C,4);

XG:T1=1 AND COUNT(T2=1,2)>0;公式,

这条件可以编辑成公式但你这条件与你截图中那四根K线是不符的

求高手编写通达信公式

LC:=REF(CLOSE,1); N:=14;
RSI:=SMA(MAX(CLOSE-LC,0),N,1)/SMA(ABS(CLOSE-LC),N,1)*100,NODRAW;
RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
K:=SMA(RSV,3,1);
D:=SMA(K,3,1);
J:=3*K-2*D;
A1:=IF(RSI>80,80-RSI,0);
A2:=IF(RSI<20,20-RSI,0);
B1:=IF(J>=100,100-J,0);
B2:=IF(J<0,0-J,0);
A1+B1+A2+B2;
你的A和B条件过多,A=80-RSI A=(20-rsi)。
只能根据你的大概意思编写了。

股票通达信公式编写

去理想论坛提问。